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TASK 1: 

 Identify the peripherals of a computer, components in a CPU and its functions. Draw the 

block diagram of the CPU along with the configuration of each peripheral. 

 

AIM: To identify the peripherals of a computer. 

 

 

BLOCK DIAGRAM OF COMPUTER 

 

A computer is an electronic device , which takes data as input, process input and produces 

information as output. A computer can process data, pictures, sound and graphics. They can 

solve highly complicated problems quickly and accurately. 

 

INPUTUNIT 

Computers need to receive data and instruction in order to solve any problem. Therefore we 

need to input the data and instructions into the computers. The input unit consists of one or 

more input devices. Keyboard is the one of the most commonly used input device. Other 

commonly used input devices are the mouse, floppy disk drive, magnetic tape, etc.  

All the input devices perform the following functions. 

1. Accept the data and instructions from the outside world. 

2. Convert it to a form that the computer can understand. 

3. Supply the converted data to the computer system for further processing. 

 Storage Unit:  The storage unit of the computer holds data and instructions that are 

entered through the input unit, before they are processed. It preserves the intermediate 

and final results before these are sent to the output devices. It also saves the data for the 
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later use. The various storage devices of a computer system are divided into two 

categories. 

 Primary Storage:  

Stores and provides very fast. This memory is generally used to hold the program 

being currently executed in the computer, the data being received from the input unit, the 

intermediate and final results of the program. The primary memory is temporary in 

nature. The data is lost, when the computer is switched off. In order to store the data 

permanently, the data has to be transferred to the secondary memory. The cost of the 

primary storage is more compared to the secondary storage.  

 Secondary Storage:  

Secondary storage is used like an archive. It stores several programs, documents, 

data bases etc. The programs that you run on the computer are first transferred to the 

primary memory before it is actually run. Whenever the results are saved, again they get 

stored in the secondary memory. The secondary memory is slower and cheaper than the 

primary memory. Some of the commonly used secondary memory devices are Hard disk, 

CD, etc., 

 Memory Size: 

All digital computers use the binary system, i.e. 0’s and 1’s. Each character or a number 

is represented by an 8 bit code. 

The set of 8 bits is called a byte. A character occupies 1 byte space. 

A numeric occupies 2 byte space. 

Byte is the space occupied in the memory. 

The size of the primary storage is specified in KB (Kilobytes) or MB (Megabyte). One 

KB is equal to 1024 bytes and one MB is equal to 1000KB. The size of the primary 

storage in a typical PC usually starts at 16MB. PCs having 32 MB, 48MB, 128 MB, 

256MB memory are quite common. 

 Output Unit: 

The output unit of a computer provides the information and results of a 

computation to outside world. Printers, Visual Display Unit (VDU) are the commonly 

used output devices. Other commonly used output devices are floppy disk drive, hard 

disk drive, and magnetic tape drive. 
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 Arithmetic Logical Unit: 

All calculations are performed in the Arithmetic Logic Unit (ALU) of the 

computer. It also does comparison and takes decision. The ALU can perform basic 

operations such as addition, subtraction, multiplication, division, etc and does logic 

operations viz, >, <, =, ‘etc. Whenever calculations are required, the control unit transfers 

the data from storage unit to ALU once the computations are done, the results are 

transferred to the storage unit by the control unit and then it is send to the output unit for 

displaying results. 

 Control Unit: 

It controls all other units in the computer. The control unit instructs the input unit, 

where to store the data after receiving it from the user. It controls the flow of data and 

instructions from the storage unit to ALU. It also controls the flow of results from the 

ALU to the storage unit. The control unit is generally referred as the central nervous 

system of the computer that control and synchronizes its working. 

 Central Processing Unit: 

The control unit and ALU of the computer are together known as the Central 

Processing Unit (CPU). The CPU is like brain performs the following functions: 

• It performs all calculations. 

• It takes all decisions. 

• It controls all units of the computer. 

A PC may have CPU-IC such as Intel 8088, 80286, 80386, 80486, Celeron, Pentium, 

Pentium Pro, Pentium II, Pentium III, Pentium IV, Dual Core, and AMD etc. 

 

Introduction to Computer Hardware: 

Hardware is the physical appearance of the devices or tools. It is what which we can touch 

and feel. Computer Hardware consists of the Monitor, CPU, Keyboard, Mouse and all other 

devices connected to the computer either externally or internally. 

A typical computer (personal computer, PC) consists of a desktop or tower case (chassis) 

and the following parts: 

1. CPU The central processing unit contains the heart of any computer, the processor. The 

processor is fitted on to a Mother Board. The Mother Board contains various 

components, which support the functioning of a PC.  
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2. System board/Motherboard which holds the Processor, Random Access Memory and 

other parts, and has slots for expansion cards . 

 

3. RAM (Random Access Memory) 

For program execution and short term data-storage, so the computer doesn't have 

to take the time to access the hard drive to find something. More RAM can contribute to a 

faster PC. The main memory of the computer is called as Random Access Memory 

(RAM). The name derives from the fact that data can be stored in and retrieved at 

random, from anywhere in the electronic main memory chips in approximately the same 

amount of time, no matter where the data is. 

Main memory is in an electronic or volatile state. When the computer is off, main 

memory is empty, when it is on it is capable of receiving and holding a copy of the 

software instructions, and data necessary for processing. 

Because the main memory is a volatile form of storage that depends on electric power 
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can go off during processing, users save their work frequently on to non volatile 

secondary storage devices such as diskettes or hard disk. 

The main memory is used for the following purposes: 

1. Storage of the copy of the main software program that controls the general 

operation of the computer. This copy is loaded on to the main memory when the 

computer is turned on, and it stays there as long as the computer is on.  

2. Temporary storage of a copy of application program instruction, to be received by 

CPU for interpretation and processing or execution.  

3. Temporary storage of data that has been input from the key board, until 

instructions call for the data to be transferred in to CPU for processing.  

Temporary storage of data, which is required for further processing or transferred as 

output to output devices such as screen, a printer, a disk storage device. 

4. ROM (Read Only Memory) 

Instructions which are critical to the operation of a computer are stored 

permanently on Read only Memory. (ROM) chip installed by the manufacturer inside the 

computer. This ROM chip is also called firm ware, retains instructions in a permanently 

accessible nonvolatile form. When the power in the computer is turned off, the 

instructions stored in ROM are not lost. 

It is necessary and also convenient to have instructions stored in ROM. The more 

instructions in ROM, the fewer diskettes you may have to handle. Until recently the 

process of manufacturing ROM chips and recording data on them was more expensive 

than the process of producing RAM chips. As a result the manufacturers tended to record 

in ROM only those instructions that were crucial to the operation of the computer. 

Today, due to improvements in the manufacturing process of ROM chips have 

lowered the cost to the point where manufacturers are beginning to include additional 

software instructions. Types of ROM’S 1.PROM 2.EPROM 3.EEPROM 

PROM  works similar to that of ROM. PROM chips are custom made for the user 

by the manufacturer. The user determines what data and instructions are to be recorded 

on them. The data on PROM is permanent and cannot be erased. 
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Erasable programmable read only memory (EPROM), developed as an improvement over 

PROM. The data on the EPROM can be read with the help of a special device that uses 

ultra violet light. The data or instructions on the EPROM are erasable and new data can 

be entered in its place. EPROM functions exactly same as PROM. 

Electronically erasable programmable read only memory (EEPROM) avoids the 

inconvenience of having to take chips out of the computer to change data and 

instructions. The only disadvantage of EEPROM is, the regular ROM chips. 

Differences between ROM &RAM 

ROM (Read only memory)  

1. You can only read the data.  

2. Data can’t be written every time, to write the data we need PROM, EPROM, OR 

EEPROM.  

3. ROM is non volatile in nature. The data stored in ROM is permanent in nature.  

4. Size of the ROM has nothing to do with processing.  

RAM (Random access memory):  

1. You can read and write data on the chip.  

2. RAM has volatile memory. It looses its contents when the power is switched off.  

3. Size of the RAM makes difference in the processing i.e., bigger the size of the 

RAM more is the speed of processing.  

4. The data can be read and written at anytime.  

1.Dynamic RAM (DRAM) 

 

2.Synchronous DRAM (SDRAM) 
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3. Static RAM (SRAM) 

 

4. Buses: PCI bus, PCI-E bus, ISA bus (outdated), USB, AGP 

 

5.Power Supply - a case that holds a transformer, voltage control and fan 

 

 

6. Storage controllers, of IDE, SCSI or other type, that control hard disk, floppy disk, 

CD-ROM and other drives; the controllers sit directly on the motherboard (on-board) or 

on expansion cards 

7. Video display controller that produces the output for the computer display 

8. Computer bus controllers (parallel, serial, USB, Fire wire) to connect the computer to 

external peripheral devices such as printers or scanners 
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9. Some type of a removable media writer:  

10. CD - the most common type of removable media, cheap but fragile.  

      CD-ROM, , CD-RW,  CD-R,  DVD,  DVD-ROM.,  DVD-RW,  DVD-R,  

 

 

11. Floppy disk 

 

Floppy Disk Drive 

 

12. Tape Drive - mainly for backup and long-term storage 

13. Internal storage - keeps data inside the computer for later use. 

14. Hard disk - for medium-term storage of data. 
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15. Disk array controller 

 

16. Sound card - translates signals from the system board into analog voltage levels, 

and has terminals to plug in speakers. 

 

17. Networking - to connect the computer to the Internet and/or other computers 

 

18. Modem - for dial-up connections 
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19. Network card - for DSL(Digital Subscriber Line)/Cable internet, and/or 

connecting to other computers. 

 

20. Other peripherals: In addition, hardware can include external components of a 

computer system. The following are either standard or very common. 

Standard input devices:     

1. Keyboard 

 

2.Mouse 

 

 Alternate input devices: Pens,Touch screens,Game controllers(joy stick),Touch 

pad,Trackball. 

   Optical  input devices:  Barcode reader, Image scanners. 

 Audio visual input devices: Microphones, Video input ,Digital cameras 
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21. Output : The output devices are: 

Standard output devices:  

Types of monitors 

CRT (cathode ray tube) monitors 

 

2. LCD(liquid crystal display) monitors 

                      

3.Printer 

Types of printers 

Impact printers: An impact printer creates an image by using pins or hammers to 

press an inked ribbon against the paper. ex. Dot matrix printer. 

Non impact printers: This type uses other means to create an image for example in 

ink jet printers tiny nozzles are used to spray droplets of ink on the page.ex: Ink jet 

printer 

Other output devices:  

Speakers, LCD projectors, Networking, Network card 

Speakers, LCD projectors     
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TASK 2: 

Assembling and disassembling the PC back to working condition.  

AIM: To assemble and disassemble the system 

 

Safety Precautions: 

1. Beware of electrostatic discharge (ESO) 

2. Build computer on a hard surface, away from concepts. 

3. Wear shoes and the short sleeved cotton wear. 

4. Use Phillips, head screw driver. 

5. Keep the components away from moisture. 

6. Avoid using pressure while installing. 

Steps for Assembling 

 

 Fix the SMPS on the cabinet of PC using the screws provided. 

 Fix the motherboard on the cabinet of PC using the screws provided. 

 Connect the power cables from SMPS to motherboard. 

 Insert the preprocessor into the slot provided such that the corner with no pin 

coincide with corner without pinhole on motherboard. 

 Apply the appropriate adhesive  on the processor for fixing the processor fan. 

 Fix the processor fan on the processor and use clips on it to keep it firm. 

 Connect the power cable to the processor fan 

 Insert the RAM card into the slots provided on the motherboard. 

 Set the jumpers setting on the hard disc drive. 

 Fix the hard disc drive in the space provided in the PC cabinet using screws 

provided. 

 Fix the FDD in the space provided in the PC cabinet using screws provided. 

 Fix the CD-ROM in the space provided in the PC cabinet using screws provided. 

 Connect the FDD,HDD, CD-ROM drive to motherboard using flat ribbon. 

 Connect power supply to the HDD, FDD, CD-ROM drive using the cables from 

the SMPS. 

 Connect wires of speakers and lights of cabinet to the motherboard. 

 Connect the network interface and other cards to motherboard by inserting in right 

slots and fix them in cabinet using the screws provided. 

 Place the cabinet in right position. 
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 Fix the doors of the cabinet. 

 Connect the data cable of monitor to the CPU. 

 Connect the keyboard cable to the CPU. 

 Connect the mouse cable to the CPU. 

 Connect other devices to CPU. 

 Connect the LAN cable to NIC in CPU. 

 Connect the power supply to CPU. 

 Connect the power supply to Monitor. 

 Switch on the computer after giving the power supply.  

 

Getting the Cabinet ready:- 

1. Check how to open the cabinet and determine where to fix the components. 

2. Determine if the case has the appropriate risers installed. 

Preparing to fit the Components: 

1.  Network adapter drive. 

2.  Floppy disk drive. 

3.  Ribbon cables. 

4.  Hard disk. 

5.  CD-ROM Drive. 

6.  RAM 

7.  CPU 

8.  Heat sink / cooler / fan. 

9.  Mother board. 

10.  Screws. 

 

Fitting the Mother board. 

1. Line up the patch on the motherboard ( ps/l, USB, etc ) with the appropriate 

holes in the block panel I/O shield of the case. 

2. Check the points where you and to install 

3. Install them and make the mother board sit on them and fix screws if required. 

Fitting the processor: 

   1. Raise the small lever at the side of the socket. 

  2. Notice that there is a pin missing at one corner, determine the direction to fit 

in the processor. 
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3. You should not force the CPU. When inserting it. All pins should slide 

smoothly into the socket. 

4. Lock the lever back down. 

5. Install the heat sink over it (Different type for each processor). Heat sink / 

CPU fan.  

 Fitting the RAM: 

1. The RAM must be suitable for motherboard. 

2. There are currently 3 types of RAM available. 

a) SD RAM. 

b) DDR SD RAM. 

c) RD RAM. 

3. The mother board’s chipset determines which type of RAM may be used. 

Installing the PCI Cards: 

1. Most of the cards are inbuilt these days. 

2. NIL, Sound Cards etc. are fitted into PCI slots. 

Fitting the hard disk and Floppy disk: 

1. Place the floppy and hard disks in their slots. 

2. Leave some space above HDD to prevent heat building. 

3. Check the jumper configuration. 

4. Fix the screws. 

Installing the CD-ROM Drives: 

1. CD-ROM drive is similar to installing a hard disk. 

2. 1ST check that the jumper configuration is correct. 

3. Fix the screw. 

Connecting the ribbon Cables:- 

1. Attach the long end of the cable to the IDEU connector on the motherboard 

first. 

2. The red stripe on the IDE cable should be facing the CD Power. 

Powering the driver and motherboard: 

       Connecting the cables for the case front pane 

        1. SD, SPK or SPEAK: The loud speakers o/p. it has 4 pins. 

        2. RS, RE, RS or RESET: Connect the two pin Reset cable here. 

3. PWR, PW, PWSW, PS or power SW: Power switch, the pc’s on (switch, the 

plug is two pin ). 
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4. PWLED, PWRLED or Power LED: The light emitting diode on the front panel 

of the case illuminates when the computer is switched on. It’s a 2-pin cable. 

       5. HD, HDD, and LED: These two pins connect to the cable for the hard disk activity 

LED. 

Final Check:- 

1. Mother board jumper configurations are the settings for the processor 

operator. 

2. Drive jumper settings, master/ slave correct? 

3. Are the processor, RAM modules and plug in cards finally seated in there 

sockets? 

4. Did you plug all the cables in? Do they all fit really? 

5. Have you frightened all the screws in plug- in cards or fitted the clips? 

6. Are the drive secure? 

7. Have u connected the power cables to all driver? 

Powering up for the first time: 

1. Ensure that no wires are touching the CPU heat sink fan. 

2. Plug your monitor, mouse and keyboard. 

3. Plug in power card and switch the power supply. 

4. If everything is connected as it should be 

 All system, fans should start spinning. 

 U should hear a single beep and after about 5-10 sec. 

 Amber light on monitor should go green. 

 You will see computer start to boot with a memory check. 

 Now check front LED’S to see if u plugged them in correctly. 

 Check all other buttons. 

 Power afford change any wrong settings. 

Steps for Dissembling 

 Switch of the power supply 

 Disconnect the power supply cable from monitor. 

 Disconnect the power supply cable from CPU. 

 Disconnect the LAN cable to NIC in CPU. 

 Disconnect the other devices in CPU such as printers. 

 Disconnect the mouse cable from CPU. 
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 Disconnect the keyboard cable from CPU. 

 Disconnect data cable of monitor from CPU. 

 Remove the doors of cabinet. 

 Place the cabinet such that motherboard faces the ceiling. 

 Disconnect the NIC and other cards from mother board by removing from slots 

and unscrewing from cabinet. 

 Disconnect the wires of speakers from mother board. 

 Remove power supply cables from HDD, FDD, CD-ROM drive etc. 

 Disconnect the HDD, FDD, CD-ROM drive from mother board by removing  flat 

ribbon cable. 

 Remove CR-ROM from cabinet. 

 Remove the FDD from cabinet by unscrewing it. 

 Remove the HDD from cabinet by unscrewing it. 

 Removing RAM cards from slots on mother board. 

 Disconnect the power cables from processor fan. 

 Remove the processor fan by unlocking clips on it. 

 Disconnect the power cables from SMPS on power cabinet. 

 Remove mother board from cabinet by unscrewing it. 

 Remove the SMPS from cabinet of PC by unscrewing it. 
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TASK 3 

 

 Install MS windows on the personal computer. 

 

INSTALLATION OF WINDOWS XP:  

 

AIM: To  install Windows XP 

Windows XP (codename Whistler, also known as Windows NT 5.1) is the latest 

desktop version of the Microsoft Windows operating system. It was made publicly 

available on October 25, 2001. Two editions of Windows XP are most commonly 

available: Windows XP Home Edition which is targeted at home users and Windows XP 

Professional which has additional features such as dual-processor support and the ability 

to join a domain, a grouping of centrally managed Windows computers. The letters "XP" 

originate from the word "Experience".  

Step 1 : Prepare The Boot Sequence 

              Insert the windows XP cd in your cdrom and than go to the BIOS by hitting 

“DEL” or “F12″ when your system in powering on. Go to Boot order and make sure 

cdrom is on the first place.Save settings and restart your computer. 

Once you have successfully booted from the CD, you will see the Windows XP 

“Welcome to Setup” screen. Press ENTER to begin the setup process. 
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Step 2: Accept the license agreement 

When you see the Windows XP license agreement press F8 to accept it and proceed. 

 

Step 3: Searching for Previous Versions of Windows XP 

Setup will search for existing Windows installations. You will see the next “repair or 

install fresh copy” screen appear only if a Windows installation currently exists on your 

machine. If you’re installing on a brand-new hard drive, skip to Step 5. 
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Step 4:Continue Installing a Fresh Copy 

Press ESC. You will be given a list of partitions available on your hard drive. 

 

 

Step 5: Partitions 

 

             If there are multiple partitions on your hard drive, or you have multiple hard 

drives in the computer, use the UP or DOWN arrow keys to choose your install partition. 

Please note that your system partition needs to be a primary partition (usually the first 

partition that shows up in the list), not a logical partition. 

The partition should be at least 10 GB in size. Make sure that all the data you need from 

this partition is copied elsewhere, because it will be deleted. 

Once you have selected the right partition selected, press ENTER. You will see the next 

“you already have a system installed” screen only if you already have Windows installed 

on this partition. If you are installing on a brand-new hard drive, skip to Step 7. 
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Step 6: Continue Installing On The Selected Drive 

Press C to continue. You will be given a list of install options 

 

Step 7: Format The Selected Partition 

Select the option to “Format the partition using the NTFS file system (quick) and press 

ENTER. You will receive a warning about formatting the drive unless the drive is brand-

new. 
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Step 8: Continue With The Format 

Press F to continue formatting selected partition. If you still haven’t backed up, this is the 

last change to backup your important data, after this step you will not to able to go back 

and restore your data. 

 

Step 9: Copying Files 

After the format setup will automatically copy files and restart your computer. Go to 

BIOS and remove cdrom from first boot device. Start your computer. 

/  

 

STEP 10: Setup will show a progress box and reboot when copying files is complete. 

When you see the "Press any Key to Reboot" do not Press any Key. If CD boots anyway, 

remove CD and reboot. 
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Step 11:From this point, you will follow the on screen prompts. 

 

Step 12:If you live outside the US, you will probably need to modify the default settings. 
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Step 13:If you live outside the US, you will probably need to modify the default settings. 
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Step 14:Personalize your XP Enter your Name and Organization. 

 

Step 15: Enter the Product Key. The Key is located on the back of the CD folder in the 

Retail versions, and on a holographic label with the OEM versions purchased with a 

piece of hardware. Write this key down and secure it in a safe place in case the original is 

displaced or destroyed through natural causes.  

 

Step 16:Choose a name for the computer, this should be a unique name for the computer, 

especially if it is to be connected to a network. In Pro, you are given the option of 

creating a password or leaving it blank. 
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Step 17:Set your Time Zone and Time and Date. 

 

Step 18: If detected you will have the choice to choose a typical  configuration or custom. 

Choose typical if you are unsure. 
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Step 19: For home you will choose your workgroup, if a network is already established 

and you intend to connect to it, use the existing workgroup name, otherwise, I suggest 

using the default. 

 
Step 20:For Pro, the same goes for Pro as suggested for Home, but you will have the 

choice to join a Domain, if you do not have a Domain or do not know leave blank. 

Setup will continue and reboot when completed ignore the "Press Any Key". 

The XP loading window will now display after reboot. 
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TASK-4: 

Introduction to device drivers, assemblers,compilers,Interpreters,linkers,loaders. 

AIM:To give the brief description about the  memory & storage devices : 

Storage Definition  

 DEVICE DRIVERS: 

 

A driver is a small piece of software that tells the operating system and other 

software how to communicate with a piece of hardware.  

For example, all printers come accompanied with drivers to install that tell the 

operating system exactly how to print information on the page. Sound card drivers tell 

your software exactly how to translate data into audio signals that the card can output to a 

set of speakers. The same applies to video cards, keyboards, monitors, etc. 

A device driver is a component that Windows uses to provide I/O services for and 

interact with an underlying device, such as a modem or network adapter. Rather than 

access the device directly, Windows loads device drivers and calls functions in the 

drivers to carry out actions on the device. The driver functions contain the device-specific 

code needed to carry out actions on the device. Device drivers for Windows Server 2003 

are usually library files with .sys filename extensions.Windows Server 2003 installs and 

configures device drivers automatically. This saves you from needing to allocate 

resources manually or check for conflicts in devices. 

Windows Server 2003 checks for a digital signature during device driver 

installation and issues a message if the driver is not signed. Windows Server 2003 checks 

a database of known problem drivers when a computer is started or when a device driver 

is loaded; if a driver is located in the database of known problem drivers, that driver 

cannot be loaded, installed, or used on the computer. 

Device Driver Dependencies and Interactions 

Plug and Play 

For automatic configuration of device drivers to occur, the system should have a 

BIOS compatible with Plug and Play. Plug and Play technology provides software and 

hardware support that enables the Windows operating system to detect and configure the 
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hardware with little or no user involvement. This makes it easier to add and configure 

hardware on a computer running Windows Server 2003 without needing special 

knowledge about hardware configurations. 

Power Management 

Windows Server 2003 offers enhanced power-management features for desktop 

and mobile computers. The operating system supports the Advanced Configuration and 

Power Interface (ACPI) specification, which provides reliable power management and 

system configuration features. Devices and drivers designed in compliance with the ACPI 

specification work with the operating system to respond to or request changes in the 

system power state. 

Device Drivers  

 
 

ASSEMBLERS: 

An assembler is a type of computer program that interprets software programs 

written in assembly language into machine language, code and instructions that can be 

executed by a computer.  

An assembler enables software and application developers to access, operate and 

manage a computer's hardware architecture and components.  

An assembler is sometimes referred to as the compiler of assembly language. It 

also provides the services of an interpreter. 
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COMPILER: 

A program that translates source code into object code. The compiler derives its 

name from the way it works, looking at the entire piece of source code and collecting and 

reorganizing the instructions. Thus, a compiler differs from an interpreter, which analyzes 

and executes each line of source code in succession, without looking at the entire 

program. The advantage of interpreters is that they can execute a program immediately. 

Compilers require some time before an executable program emerges. However, programs 

produced by compilers run much faster than the same programs executed by an 

interpreter.  

Every high-level programming language (except strictly interpretive languages) 

comes with a compiler. In effect, the compiler is the language, because it defines which 

instructions are acceptable.  

Because compilers translate source code into object code, which is unique for 

each type of computer, many compilers are available for the same language. For example, 

there is a FORTRAN compiler for PCs and another for Apple Macintosh computers. In 

addition, the compiler industry is quite competitive, so there are actually many compilers 

for each language on each type of computer. More than a dozen companies develop and 

sell C compilers for the PC.  

LINKER : 
 

Also called link editor and binder, a linker is a program that combines object 

modules to form an executable program. Many programming languages allow you to 

write different pieces of code, called modules, separately. This simplifies the 

programming task because you can break a large program into small, more manageable 

pieces. Eventually, though, you need to put all the modules together. This is the job of the 

linker.  
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LOADER: 

In a computer operating system , a loader is a component that locates a given 

program (which can be an application or, in some cases, part of the operating system 

itself) in offline storage (such as a hard disk ), loads it into main storage (in a personal 

computer, it's called random access memory ), and gives that program control of the 

computer (allows it to execute its instruction s). 

A program that is loaded may itself contain components that are not initially 

loaded into main storage, but can be loaded if and when their logic is needed. In a 

multitasking operating system, a program that is sometimes called a dispatcher juggles 

the computer processor's time among different tasks and calls the loader when a program 

associated with a task is not already in main storage. (By program here, we mean a binary 

file that is the result of a programming language compilation, linkage editing, or some 

other program preparation process.) 

I/O PORTS: 

Alternatively referred to as I/O address, I/O ports, and I/O port address, the 

input/output port is what allows the software drivers to communicate with hardware 

devices on your computer. In your computer there are 65,535 ports that are numbered 

from 0000h to FFFFh. 

The I/O port assignment can be made either manually using DIP switches or 

automatically using PnP. When configuring the I/O port of any device in your computer, 

it is important that it does not share the same I/O port as another device or you will 

encounter a hardware conflict. 
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TASK 5(a): 

 Identify the problem in PC which does not boot due to improper assembly or 

defective peripherals, fix it to get the computer back to working condition.  

AIM: Hardware troubleshooting 

Troubleshoot:- 

1. If you hit the power button & nothing happened. 

 Check all power connections. 

 Check for power on mother board.   

2. If the system turns on but does not beep or begin to boot up. 

 Remove all components except motherboard/ cpu / mother 

check by giving power to them  

     Computer error beeps codes: 

No beep: short, no power, bad CPU/ MD, loose peripherals. 

One beep: everything is normal & computer posted tax. 

Two beeps: post / CMOS error. 

One long beep One short beep: Motherboard problem. 

One long beep two short beep: video problem. 

One long beep 3 short beeps: video problem. 

3 long beeps: keyboard error. 

Repeated long beep:  memory error. 

Continuous high- low beeps: CPU overheating Experiment no: 1 

 

Basic troubleshooting: 

 

Sometimes things do not work exactly as planned at this point. Sometimes the system 

will not power on at all. Sometimes it will power on, but you get no video. Sometimes 

you will get beep codes. Sometimes you hear the fans, but the rest of the PC just sits there 

and does nothing. If things didn't go according to plan, troubleshoot the system. Walk 

mentally through the boot process and check all hardware as it goes. Think like the 

computer thinks, if you know what I mean. Here is a list of some of the more common 

problems.  

1. The power does not even turn on. This sometimes happens on ATX machines and 

it usually tracks down to the fact that the power switch is not properly connected 

to the motherboard or it is not connected at all. Find the power switch lead and 
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make sure it is connected to the motherboard. It’s a possibility that simply 

reversing the lead will do the trick. If this is the not the case, then make sure the 

motherboard is not grounded somehow. Make sure that the board is not touching 

the case (this is what the spacers are for). Make sure that none of the screws that 

hold the board in place is touching anything metal or any of the electrical 

pathways on the motherboard. If you have any doubt on this, you can remove 

each screw one at a time and place a washer on them. You do not need to remove 

the motherboard to do this.  

2. The PC boots, but it is giving beep codes. This is actually better than having to 

track everything down on your own, because at least the PC is giving you a hint 

as to what is wrong. You can also use the PC Mechanic Beep Codes E-book 

available on the PC Mechanic CD to track it down for other BIOS versions. 

Often, these beep codes will not tell you exactly what the problem is, but will 

point you at the trouble device. This information will then get you pointed in the 

correct direction. 

3. The fans come on, but you get no video or beeps. Sometimes, this is because 

some key component may not be plugged in well or may not be operational. 

Check the memory modules and the processor to be sure they are firmly installed. 

You might want to make sure the processor is actually working. One way that I 

have used to see if a processor is working is to remove or unplug the CPU fan and 

place your fingers on the CPU to see if it heats up real fast. If it does, its OK and 

don’t let it run this way for long. If it remains at room temperature for awhile, 

then there is no juice going through the processor and it may need replacing. The 

keyboard doesn’t seem to work. This one doesn’t happen too often, but if it does, 

your two trouble sources will be the keyboard itself or the keyboard controller on 

the motherboard. Hope it isn’t the second one. 

 

 

 

 

 

 

 

www.FirstRanker.com www.FirstRanker.com

www.FirstRanker.com



www.F
irs

tR
an

ke
r.c

om

B.TECH 1 YEAR-2nd SEMESTER                                          COMPUTER SCIENCE & ENGINEERING 

VSM COLLEGE OF ENGINEERING                   34                                           IT WORKSHOP 

 

TASK 5(b): 

Identify the malfunctioning CPU due to system software problems. Fix the problem 

to get the computer back to working condition.  

AIM: Software troubleshooting 

PROCEDURE: 

Error messages encountered during boot before Windows loads 

Ensure that your computer BIOS settings are correctly configured to the hardware that is 

installed in your computer 

Error messages while windows loading 

1.If you have recently installed or changed something that could have caused normal 

windows to stop loading , try loading the last known good configuration 

2.If you are unable to get into Normal windows and believe that removing or uninstalling 

a program or changing a setting may help enable you to get into windows , boot the 

computer into windows XP safe mode 

3.If your computer has worked fine in the past but recently   has been experiencing the 

issue you are encountering run the system restore option to restore the computer to an 

earlier date 

Other error messages that occur while windows is loading or after windows is 

loaded 

1.If error occur but windows still loads , verify no issues or conflict exits in device 

manager  

2.Ensure that if programs are loading automatically that these errors are not associated 

with these programs 

3.Make sure Windows XP is up to date by checking Microsoft windows update page 

4.If your computer has virus protection installed make sure that it is up to date and that no 

virus are being detected 

5. If your computer has worked fine in the past but recently   has been experiencing the 

issue you are encountering run the system restore option to restore the computer to an 

earlier date 
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Software Troubleshooting: 
 

BIOS SETUP & DISK FORMATTING  

 

 What Is BIOS?  

BIOS is an acronym for Basic Input Output System.  

  

Why BIOS?  

To run any system, there must be default settings so that the system can load those 

settings when it is started or restarted. For a computer system the basic I/O settings and 

boot process details are necessary to start a system. All these default, predefined settings 

will be loaded in the BIOS and whenever we start the system, these settings will be 

loaded.  

 How to view BIOS?  

Whenever we start the system, we can enter into the BIOS Setup Utility by pressing Del 

Key. Sometimes an F1 or F8 key has to be instead of DEL key, depending on the type of 

BIOS. When we enter in to this utility we get these following menus/services, depending 

upon our mother board. Here, we can change the settings of PCI devices, Floppy Drives 

configuration and chipset, USB peripheral devices and even monitoring the Hardware.  

Security : 

We can set the supervisor password, to restrict unauthorized users to enter the BIOS 

setup utility.  

User password can also be set to restrict the unauthorized persons to boot or use the 

system.  

 How to type a Password?  

We can even set the Chassis Intrusion to protect the system devices from removing the 

components of the system.  

Power .The power settings protect the system from power failures by configuring the 

ACPI. For example, after power failure we can stay off the system or Power on the 

system or else we can even make the system to restore its previous state by selecting the 

appropriate options.  

 Boot  

boot : If this option is enabled it displays only the OEM logo and in the background 

POST(Power on Self Test) completes. If this is disabled, instead of LOGO, we can view 

POST messages  
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Task -6 (a) 

Demonstrating importance of network, transmission media, networking devices, 

gateway, Routers, hub, bridge, NIC, Bluetooth technology, wireless technology, 

modem, DSL, dial up connections. 

A network is a group of two or more computer systems linked together. There 

are many types of computer networks, including: 

 Local-area networks (LANs) : The computers are geographically close together 

(that is, in the same building).  

 Wide-area networks (WANs) : The computers are farther apart and are connected 

by telephone lines or radio waves.  

 Campus-area networks (CANs): The computers are within a limited geographic 

area, such as a campus or military base.  

 metropolitan-area networks MANs): A data network designed for a town or city.  

 Home-area networks (HANs): A network contained within a user's home that 

connects a person's digital devices.  

 Topology : The geometric arrangement of a computer system. Common topologies 

include a bus, star, and ring.  

 Protocol: The protocol defines a common set of rules and signals that computers on 

the network use to communicate. One of the most popular protocols for LANs is 

called Ethernet. Another popular LAN protocol for PCs is the IBM token-ring 

network .  

 Architecture: Networks can be broadly classified as using either a peer-to-peer or 

client/server architecture.  

Computers on a network are sometimes called nodes. Computers and devices that allocate 

resources for a network are called servers. 

Hubs: A common connection point for devices in a network. Hubs are commonly used 

to connect segments of a LAN. A hub contains multiple ports. When a packet arrives at 

one port, it is copied to the other ports so that all segments of the LAN can see all 

packets. 
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BRIDGES:  

A bridge device filters data traffic at a network boundary. Bridges reduce the 

amount of traffic on a LAN by dividing it into two segments. Bridges operate at the data 

link layer (Layer 2) of the OSI model. Bridges inspect incoming traffic and decide 

whether to forward or discard it. An Ethernet bridge, for example, inspects each incoming 

Ethernet frame - including the source and destination MAC addresses, and sometimes the 

frame size - in making individual forwarding decisions.  

 

Modem : 

Modulator-demodulator. Electronic device that allows computers to communicate 

over telephone wires or cable-TV cable. One computer's modem converts its digital 

signals (which cannot be sent efficiently over phone lines) into analog signals (which can 

be). The other computer's modem reconverts the analog signals (that the computer cannot 

understand) into digital signals (that it can). Conversion of one type of signals to another 

is called modulation, their reconversion to the original type is called demodulation. 

Modern modems work at 56 thousand bits per second (Kbps) or higher data transfer 

speeds, perform automatic error correction, and allow voice and fax communications.  
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TASK 6(b) 

Orientation & Connectivity Boot Camp:  Students should get connected to their 

Local Area Network and access the Internet. In the process they configure the 

TCP/IP setting. Finally students should demonstrate, to the instructor, how to access 

the websites and email. If there is no internet connectivity preparations need to be 

made by the instructors to simulate the WWW on the LAN 

PURPOSE: To learn Local Area Network and access the Internet. In the process they 

configure the TCP/IP setting. Finally students should demonstrate, to the instructor, how 

to access the websites and email  

THEORY: 

The internet is a world wide, publicly network of interconnected computer networks  

LOCAL AREA NETWORK: 

LANs are privately owned networks with in a single building or campus of up to few 

kilometers in size. 

WIDE AREA NETWORK: 

A WAN is a network that connects computers across a large geographic area such as a 

city or country 

TCP/IP (Transmission Control Protocol/Internet Protocol): 

Collection of methods used to connect servers on the internet and to exchange data. 

HTML (Hyper Text Markup Language): 

The coding used to control the look of documents on the web 

HTTP (Hyper Text Transfer Protocol): 

Part of a URL that identifies the location as one that uses HTML 

IP(Internet Protocol): 

A format for contents and addresses of packets of information sent over the internet 

IP ADDRESS: 

An identifier for a computer or device on a TCP/IP network  

SEARCH ENGINE: 

A program that searches documents located on the Internet for keywords or phrases 

entered by a person browsing the net. 

Internet Connection requirements: 

 TCP/IP protocol 

 Client Software 

 ISP Account 
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Means of communication to the net 

 telephone Modem 

 Ethernet 

 ISDN(Integrated Services Digital Network) 

 DSL(Digital Subscriber Line) 

 Satellite. 

PROCEDURE: 

1. Go to startcontrol Panel 

2. open Network Connections 

3. Click  create a new connection and then click next 

4. The  new connection wizard window opens , click next  

to continue 

5. Choose one of the options in the next dialog box 

6. Choose one of the three options in the next dialog box 

 If you do not have an internet account click 

choose from a list of ISPs  and then  click next 

 If you have an account click  Set up my 

connection manually 

 If you have a CD from the ISP click use the CD 

I got from an ISP and then click next 

7. Follow the next steps ad per the option you selected. 
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TASK 7: 

To create project certificate, Features to be covered:-Formatting Fonts in word, 

Drop Cap in word, Applying Text effects, Using Character Spacing, Borders and 

Colors, Inserting Header and Footer, Using Date and Time option in both LaTeX 

and Word. 

 

PURPOSE:  

 To create a document applying the above mentioned techniques. 

THEORY:   

      Header and Footer: 

1. To create a header, enter text or graphics in the header area or click 

button on the header and footer tool bar. 

                    2. To create footer, click switch between header and footer. 

                    3. Then click exit. 

       Date and Time: 

        Insert a date field that automatically updates so that the current date is displayed 

when you open or print the file.Insert a time field that automatically updates so that the 

current time is displayed when you open or print the file. 

        Border: 

 

       On the format menu, click borders and shadings.To specify that the border 

appears on a particular side of a page, such as only at the top, click custom under 

setting.To specify a particular page or section for the borders to appear, click the option 

you want to apply.To specify the exact position of the border on the page. Finally, click 

OK. 
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Color: 

 

 Select the text you want to make a different color.To apply the color most 

recently applied to text, click font color.To apply different colors, click the arrow on the 

right of the font color button, select the color you want and then click the button. 

Procedure: 

 

First click start button on the status bar. Then select program and again select Microsoft 

word. On the menu bar click the file option. Then again click new. Then enter the text not less 

than 100 words. A header appears at the top and the footer appears at the bottom of each page. 

On the view menu, click header and footer option. From dialogue box, make the required 

changes and then click OK. On the format menu, click borders and shading s make required 

changes and the click OK. Select the text you want and make the different color. Click on 

right of the font color button, Then select the color you want and then click on the button. 
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TASK 8:  

Formatting Styles, Inserting table, Bullets and Numbering, Changing Text 

Direction, Cell alignment, Footnote, Hyperlink, Symbols, Spell Check and  Track 

Changes. 

PURPOSE:  

 To create a document applying the above mentioned techniques. 

THEORY:   

      Table: A table consists of rows and columns. 

 

Cell Alignment: 

 

Aligns contents written in a table in the top left corner or top right corner or in the center 

etc... 

     Foot Note: Foot notes are used to comments on, or provide references for text in a 

document. 

     Hyperlink: It is a colored and underlined text or a graphic that you click to go to a 

file, a location in a file, an HTML page on the World Wide Web, or an HTML page in an 

intranet. 
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  Symbols: 

 

  You may not be able to enter certain symbols into your word document, as 

there is a limitation on the keys on the key board. Creating these new symbols especially 

when working with mathematical terms it becomes very difficult .For example we can 

insert symbols such as,,, ..  

Spell check: It automatically checks for spelling and grammatical errors 

 

Bullets and Numbering: In Microsoft word we can easily create bulleted or numbered 

list of items 
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  . 

Formatting Styles: 

 

  A style is a set of rules to be followed for the effective document. Style 

can be applied to text, paragraph, table or a list. 

Changing text direction: 

 

You can change the text orientation in drawing objects, such as text boxes, shapes, and 

callouts, or in table cells so that the text is displayed vertically or horizontally. 

Track changes: 

  Track changes are an excellent feature of Microsoft word as it enables a 

user or reviewer to keep track of the changes that have taken a period. Changes like 

insertion, deletion or formatting changes can be kept track of. 

Procedure: 

Changing Text direction: 

1. Click the drawing object or table cell that contains the text you want to change.  

2. On the Format menu, click Text Direction.  

3. Click the orientation you want. 

Table: 

www.FirstRanker.com www.FirstRanker.com

www.FirstRanker.com



www.F
irs

tR
an

ke
r.c

om

B.TECH 1 YEAR-2nd SEMESTER                                          COMPUTER SCIENCE & ENGINEERING 

VSM COLLEGE OF ENGINEERING                   45                                           IT WORKSHOP 

 

 

1. Click where you want to create a table. 

2. On the Table menu, point to Insert, and then click Table. 

3. Under Table size, select the number of columns and rows. 

4. Under AutoFit behavior, choose options to adjust table size. 

5. To use a built-in table format, click AutoFormat. 

Select the options you want 

Cell Alignment: 

 

1. Click the cell that contains text you want to align.  

2. On the Tables and Borders toolbar, select the option for the horizontal and vertical 

alignment you want— for example, Align Bottom Center or Align Top Right.  

Foot Note: 

1. In print layout view, click where you want to insert the note reference mark.  

2. On the Insert menu, point to Reference, and then click Footnote.  

3. Click Footnotes or Endnotes.  

By default, Word places footnotes at the end of each page and endnotes at the end 

of the document. You can change the placement of footnotes and endnotes by 

making a selection in the Footnotes or Endnotes box. 

4. In the Number format box, click the format you want.  

5. Click Insert.  

Word inserts the note number and places the insertion point next to the note 

number. 
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6. Type the note text.  

7. Scroll to your place in the document and continue typing.  

As you insert additional footnotes or endnotes in the document, Word 

automatically applies the correct number format. 

 

Hyper link: 

 

Select the text or picture you want to display as the hyperlink, and then click Insert 

Hyperlink on the Standard toolbar 

Do one of the following:  

1. Link to an existing file or web page: 

1. Under Link to, click Existing File or Web Page. 

2. In the Address box, type the address you want to link to or, in the Look in 

box, click the down arrow, and navigate to and select the file. 

2. Link to a file you haven’t created yet 

Under Link to, click Create New Document. 

3. In the Name of new document box, type the name of the new file.  

4. Under When to edit, click either Edit the new document later or Edit the 

new document now 

An e-mail address: 

1. Select the text or picture you want to display as the hyperlink, and then click 

Insert Hyperlink on the Standard toolbar 

2. Under Link to, click E-mail Address. 

3. Either type the e-mail address you want in the E-mail address box, or select an e-

mail address in the recently used e-mail addresses box.  
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4. In the Subject box, type the subject of the e-mail message 

A specific location in another document  

1. Insert a bookmark in the destination file or Web page.  

2. Open the file that you want to link from, and select the text or object you want to 

display as the hyperlink. On the Standard toolbar, click Insert Hyperlink.  

3. Under Link to, click Existing File or Web Page.  

4. In the Look in box, click the down arrow, and navigate to and select the file that 

you want to link to.  

5. Click Bookmark, select the bookmark you want, and then click OK. 

1. Click where you want to insert the symbol.  

2. On the Insert menu, click Symbol, and then click the Symbols tab.  

3. In the Font box, click the font that you want.  

4. Double-click the symbol that you want to insert.  

5. Click Close 

Formatting Styles: 

 

 

1. Select the words, paragraph, list, or table you want to change.  

2. If the Styles and Formatting task pane  is not open, click Styles and Formatting on 

the Formatting toolbar 

3. Click the style you want in the Styles and Formatting task pane. 

If the style you want is not listed, click All Styles in the Show box 

 

Track Changes: 

1. Open the document you want to revise.  

2. On the Tools menu, click Track Changes 
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AIM: - Executing Mathematical Functions, Logical Functions, Text Functions, 
Date Functions and Statistical Functions in MS-Excel 
 
Main Points: -  

1. Each and every function should starts with = (equal to sign) 

2. We can execute functions either by supplying values or by supplying range of 

cells.  

3. We should use simple parenthesis to specify the value of a function. No other 

brackets are used  

4. We can get more functions by using INSERT FUNCTION command from the 

FORMULAS menu  

 
MATHEMATICAL FUNCTIONS: -  

1. POWER(X,N) It returns the value of X power N 

Example:   =POWER(2,5)  Output: 32 

2. ROUND(18.9697,2) It rounds value of X to N number of digits 

Example:  =ROUND(18.9697,2)  Output: 18.97 

3. SUM(Value1, Value2, …) or SUM(Range) It returns sum of all values in the 

given range 

 Example:  =SUM(12,23,34,45)   Output: 114 

 Example1:  =SUM(A1: A10)   Output:  

4. GCD(Value1, Value2, …) or GCD(Range) It returns greatest common divisor of 

all values in the specified range 

 Example:  =GCD(54,72,36)  Output: 9 

 Example1:  =GCD(A1: A10)   Output: 

 
LOGICAL FUNCTIONS: -  

1. AND(Condition1, Condition2, …) It returns TRUE if all conditions are TRUE. 

Otherwise it returns FLASE. 

Example:  =AND(2<3, 3<4, 5<>6) Output: TRUE 

2. OR(Condition1, Condition2, …) It returns FALSE if all conditions are FALSE. 

Otherwise it returns TRUE. 

Example:  =OR(2>3, 3<4, 5=6)  Output: TRUE 

3. NOT(Condition) It returns FALSE if given condition is TRUE. Also it returns 

TRUE if given condition is FALSE 

Example:  =NOT(6<7)   Output: FALSE 

Example:  =NOT(6>7)   Output: TRUE 

4. IF(Condition, Value1, Value2) It returns Value1 if the given condition is TRUE. 

Otherwise it returns Value2. 

Example:  =IF(6<7, “INDIA”,”AMERICA)   Output: 

INDIA 

Example:  =IF(6>7,”JNTU”,”AU”)    Output: AU 

 

TEXT FUNCTIONS: -  
1. REPT(“Text”, N) It returns the specified text for N times 

Example:  =REPT("VSM@RCPM",2) Output: VSM@RCPM 

VSM@RCPM  

2. TRIM(“Text”) It removes all additional spaces except a single space between 

words 

Example:  =TRIM("We    are VSM      students")  

Output: We are VSM students 
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3. PROPER (“Text”) It converts first letter of each word into upper case and all 

other letters into lower case. 

Example:  =PROPER("wE ArE diPLOma sTUDENts")  

Output: We Are Diploma Students 

4. CONCATENATE(“Text1”, “Text1”, …) It joins several text values to a whole 

one 

Example:   =CONCATENATE("SIMHADRI","LALITHA")  

Output: SIMHADRILALITHA 

 
DATE FUNCTIONS: -  

1. TODAY() It returns the system date in the current cell. 

Example:   =TODAY() Output: 8/15/2015 

2. DAYS360(“Date1”, “Date2”) It returns number of days between the two given 

dates based on 360 days per a year 

Example:  =DAYS360("01/01/2015","09/29/2015")  Output: 268 

3. WEEKDAY(“Date”)  It returns 1 for Sunday, 2 for Monday, …, 7 for Saturday 

corresponding to the given date. 

Example:  =WEEKDAY(TODAY())          Output: 7  

4. WEEKNUM(“Date”)  It returns the week number in the year corresponding to the 

given date. 

Example:  =WEEKNUM(TODAY())          Output: 33 

 
STATISTICAL FUNCTIONS: -  

1. AVERAGE(Value1, Value2, …) or AVERAGE(Range)  It returns the arithmetic 

mean of all values in the specified range of cells. 

Example:   =AVERAGEA(12,14,16)  Output: 14 

2. COUNTBLANK(Range)  It counts number of empty cells within the specified. 

Example:  =COUNTBLANK (A1:A10)  Output: Depending on the 

values  

between A1 to A10 

3. COUNTIF(Range, Condition)  It counts number of cells within the specified 

range that meet the specified condition. 

Example:  =COUNTIF(A1:A10,">=100") Output: Depending on the 

values between A1 to A10 

4. MAX(Value1, Value2, …) or MAX(Range) It the highest value in the specified 

range of cells. 

Example:  =MAX(12.24,12.350,12.45)          Output: 12.45 
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TASK 11 

Aim: - Create Student Marks List in Microsoft Excel and apply formulas to find 
Total, Percentage, Result and Rank 
 
Procedure: Open Microsoft Excel and take a new work book. Type details of 
students like Roll Number, Name and marks of different subjects. Then execute 

the following formulas. 
 

1. Formula to get Total Marks     =SUM(C3:H3) 
 

2. Formula to get Percentage of  Marks   =AVERAGE(C3:H3) 
 

3. Formula to get Result 
=IF(AND(C3>34, D3>34, E3>34, F3>34, G3>34, H3>34), "PASS", "FAIL") 
 

4. Formula to get Grade 
=IF(J3>90, "A", IF(J3>75, "B", IF(J3>60, "C", IF(J3>40, "D", "No Grade")))) 
 

5. Formula to get Rank     =RANK(I3,I:I) 
 

The output is as follows. 
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Aim: - Create Students Data in MS- Excel and prepare Column Chart, Bar Char 
and Pie Chat. 
 

COLUMN CHART: - A column chart is a primary Excel chart type, with data series 

plotted using vertical columns. Column chart is used to compare values across categories 

by using vertical bars. Column charts work best where data points are limited. With more 

data points, you can switch to a line graph. 

 Easy to read 
 Simple and versatile 
 Easy to add data labels at ends of bars 

Procedure: Open Microsoft Excel and take a new work book. Type details of 
students like Roll Number, Name and Marks. Then insert Column Chart from INSERT 
Menu. 
 

The output is as follows. 

 
 
PIE CHART: - Pie chart is used to display the contribution of each value (slice) 
to a total (pie). Pie charts always use one data series. 
Advantages of Pie Chart: -  

 It displays relative proportions of multiple classes of data. 
 The size of the circle can be made proportional to the total quantity it 

represents. 
 Pie chart summarizes a large data set in visual form. 
 It will be visually simpler than other types of graphs. 
 It permits a visual check of the reasonableness or accuracy of 

calculations. 
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Steps to create a pie chart: -  
1. Type the following data in a new worksheet 

Category Expenditure 

House Rent 3600 

Food 6300 

Monthly Bills 2700 

Education & Helth 2700 

Entertainment 900 

Savings 1800 

   

2. Select entire data and choose pie from the INSERT ribbon, agagin select PIE 

from 2-D Pie . 

3. Click on the chart and follow LAYOUT  Data Labels  More Data Label 

Options  Select Category Name, Value and Percentage  Close 

4. Again Click on the chart and follow LAYOUT  Legend  None  

5. Select chart title and type the heading as “Monthly Expenditure Chart” 

6. As a result the chart will be displayed as follows 
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TASK  9: 

Create a Newsletter. Features to be covered:-Table of content. Newspaper columns,  

Images from files and clipart, Drawing toolbar and Word Art, Formatting Images, 

Textboxes and Paragraphs. 

 

PURPOSE: 

 To create a news Letter  

 

THEORY: 

Table of contents:Table of contents displays a list of headings in a created document. It 

basically provides an outline of the entire document created. 

 

Newspaper columns: 

 

One can create a newspaper columns document by specifying the number of new letter-

style column required and then adjust their width, and add vertical lines between 

columns. 

Images from files and clipart: 
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Inserting a picture (graphic) from a file and clipart may be required for a 

document. This picture could be a scanned photograph or any other digitally produced 

one. These pictures can be modified, resized, cropped and enhanced. 

 

Drawing toolbar and Word Art: 

 

One can create his/her own drawings in Microsoft word. Ms word provides a full 

fledged drawing tool bar. Word Art in Microsoft word enables you to create special and 

decorative text. 

Formatting Images, Textboxes and Paragraphs: 
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Formatting an image includes selecting appropriate color, size, layout and 

cropping. Generally the text in a document follows a standard orientation (line after line). 

A text box provides a different orientation to the text with in a document. It can arrange 

the text in any where and can be resized and moreover moved to any section of the 

document or even outside. 

  When you are formatting a paragraph, you do not need to highlight the 

entire paragraph. Placing the cursor any where in the paragraph enables you to format it. 

After you set a paragraph format, subsequent paragraphs will have the same format 

unless you change the format 

PROCEDURE: 

Table of contents: 

1. Click where you want to insert the table of contents.  

2. On the Insert menu, point to Reference, and click Index and Tables.  

3. Click the Table of Contents tab.  

4. To use one of the available designs, click a design in the Formats box.  

5. Select any other table of contents options you want.  

Newspaper columns: 

1. Select the entire or part of document to be converted into a newsletter-style 

2. Click on format menu, select columns 

3. Any desired number of columns are presets-one or two or three or left or right b\can be 

selected. 

4. Width and spacing can be fixed and equal columns width can be checked for 

uniformity 

5. If newspaper columns are to be separated by a line, then check line between 

6. Under apply to will be whole document if entire document is selected else we have to 

select a selected text. 

7. Click ok 

Inserting images from files and clip art: 

1. Click where you want to insert the picture.  

2. On the Insert menu, point to Picture, and then click From File.  

3. Locate the picture you want to insert.  

4. Double-click the picture you want to insert.  
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CLIP ART: 

1. On the Insert menu, point to Picture, and then click Clip Art.  

2. In the Clip Art task pane, in the Search for box, type a word or phrase that 

describes the clip you want or type in all or some of the file name of the 

clip.  

3. To narrow your search, do one or both of the following:  

 To limit search results to a specific collection of clips, in the 

Search in box, click the arrow and select the collections you want 

to search.  

 To limit search results to a specific type of media file, in the 

Results should be box, click the arrow and select the check box 

next to the types of clips you want to find.  

4. Click Go.  

5. If you don't know the exact file name, you can substitute wildcard characters 

for one or more real characters. Use the asterisk (*) as a substitute for zero or 

more characters in a file name. Use the question mark (?) as a substitute for a 

single character in a file name. 

6. In the Results box, click the clip to insert it.  

Drawing Toolbar and Word Art: 

1. Click in your document where you want to create the drawing.  

2. On the Insert menu, point to Picture, and then click New Drawing.  

A drawing canvas is inserted into your document. 

3. Use the Drawing toolbar to add any shapes or pictures that you want.  

WORD ART: 
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1. On the Drawing toolbar, click Insert WordArt .  

2. Click the WordArt effect you want, and then click OK.  

3. In the Edit WordArt Text dialog box, type the text you want. 

4. Do any of the following:  

 To change the font type, in the Font list, select a font.  

 To change the font size, in the Size list, select a size.  

 To make text bold, click the Bold button.  

 To make text italic, click the Italic button.  

Formatting Images: 

1. Formatting of the images can be achieved by selecting the image and double click on 

the picture, format picture dialog box appears. 

2. The same can be achieved by selecting the tools menu  customizetool bars 

tabpicture and click close. 

Basic formatting features of an image 

Resize a drawing 

1. Select the drawing canvas 

2. On the Drawing Canvas toolbar, do one of the following: 

o To make the drawing canvas boundary larger without changing the size of the 

objects on the canvas, click Expand. 

o To make the drawing canvas boundary fit tightly around the drawing objects 

or pictures, click Fit. 

o To scale the drawing and make the objects and canvas proportionately smaller 

or larger, click Scale Drawing, and then drag the edges of the canvas. 

Resize a picture or shape 

1. Position the mouse pointer over one of the sizing handles  

2. Drag the sizing handle until the object is the shape and size you want.  

To increase or decrease the size in one or more directions, drag the mouse away 

from or toward the center, while doing one of the following:  

o To keep the center of an object in the same place, hold down CTRL while 

dragging the mouse.  

o To maintain the object's proportions, drag one of the corner sizing handles.  

o To maintain the proportions while keeping the center in the same place, 

hold down CTRL while dragging one of the corner sizing handles. 

www.FirstRanker.com www.FirstRanker.com

www.FirstRanker.com



www.F
irs

tR
an

ke
r.c

om

B.TECH 1 YEAR-2nd SEMESTER                                          COMPUTER SCIENCE & ENGINEERING 

VSM COLLEGE OF ENGINEERING                   58                                           IT WORKSHOP 

 

Crop a picture 

 

1. Select the picture you want to crop.  

2. On the Picture toolbar, click Crop.  

3. Position the cropping tool over a cropping handle and then do one of the 

following:  

o To crop one side, drag the center handle on that side inward.  

o To crop equally on two sides at once, hold down CTRL as you drag the 

center handle on either side inward.  

o To crop equally on all four sides at once, hold down CTRL as you drag a 

corner handle inward.  

4. On the Picture toolbar, click Crop to turn off the Crop command. 

Text Box: 

1. On the Drawing toolbar, click Text Box .  

2. Click or drag in your document where you want to insert the text box 

3. You can use the options on the Drawing toolbar to enhance a text box— for 

example, to change the fill color— just as you can with any other drawing object 

Paragraphs: 

 

 

Change line spacing  

Select the text you want to change. 
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1. On the Formatting toolbar, point to Line Spacing, and then do one of the 

following:  

o To apply a new setting, click the arrow, and then select the number that 

you want.  

o To apply the most recently used setting, click the button.  

o To set more precise measurements, click the arrow, click More, and then 

select the options you want under Line Spacing.  

Change spacing before or after paragraphs 

1. Select the paragraphs in which you want to change spacing.  

2. On the Format menu, click Paragraph, and then click the Indents and Spacing tab.  

3. Under Spacing, enter the spacing you want in the Before or After box.  

Change paragraph direction 

1. Place the insertion point in the paragraph that you want to change, or select 

several paragraphs.  

2. Do one of the following:  

o To have text begin from the left, click Left-to-Right on the Formatting 

toolbar.  

o To have text begin from the right, click Right-to-Left on the Formatting 

toolbar.  

When you change the paragraph direction, Microsoft Word leaves justified and centered 

text as it is. In the case of left-aligned or right-aligned text, Word flips the alignment to 

its opposite. For example, if you have a left-to-right paragraph that is right aligned, such 

as the date at the top of a letter, clicking Right-to-Left results in a right-to-left paragraph 

that is left aligned. 
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TASK 10: 

Creating a Feed Back Form:-Features to be covered: Forms, Text Fields, Inserting 

objects and Mail Merge in Word. 

 

PURPOSE: To create a Feed Back form, text fields, inserting objects, mail merging, 

THEORY: 

Forms: 

 Using Microsoft word one can create an organized and structured document with 

a provision to enter the required information into it. A document of such nature is called a 

form. 

Mail Merge: 

 

 It helps us to produce from letters mailing labels envelopes catalogs and others 

types of merged document. It is so found in the tools option on the menu bar. In tools we 

have letters and mailing. In letters and mailing we have mail merge mail merge tool box 

envelopes tables and letters wizard. In mail merge select the required document you are 

working on. A window for customizing the data base structure appears. This file contains 

the names, address details with contact numbers etc of people you wish to send the 

letters. 
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Inserting objects: 

 Insert an object such as drawing word art text effects or an equation at the 

inserting point. 

Fields: 

 It inserts a field at the inserting font fields are used to insert a variety of 

information automatically. Select table in table select insert. In that select insert table a 

box containing number of rows and columns will appear. Select six colors and four rows 

and click o.k. Given the first row as date, problem repeated student’s signature action 

recommended problem status and councilors sign. Insert the objects in the feed back form 

and apply the text fields in the  

form. 

PROCEDURE: 

Mail Merge: 

1. Open a document and type the complete body of the letter and format it as 

required. 

2. Create a data source and choose mail merge from tool bar a window is 

displayed. 

3. Click on create button and choose from letter options. Then a window is 

displayed. 

4.  Click active window choose currently active document. Click on data and 

create data source option. 

5. A window for customizing the data base structure appears and this file contains 

the names address details with contact number etc. we can add or remove 

fields from this file. 

6. Once the list of fields is finalized a window of same is displayed and types the 

required file names and click on save button. 

7. A window is displayed. Type the details of 10 candidates. After typing details 

of one person, click on add menu. 

8. Click on the o.k. to finish entering the records mail merge tool bar is displayed. 

9. Place the curser at the place where you wish to insert names and click on insert 

mail merge button. A drop list is displayed all fields created would be shown. 

10. By highlighting to desired file and click on it we can insert the field into the 

main document and go to begin the mail merge click on mail merge. 
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          11. A window is displayed click once on the merge button to generate letters for all 

records in your data source file. 

Forms: 

1. Design the form by sketching a layout first, or use an existing form template as a 

guide. Tables, text boxes, borders, and shading are all design elements that can 

help you create a well-designed form that's easy to use. 

2. On the Standard toolbar, click New Blank Document .  

3. Add the text or graphics you want. For example, enter the questions you want 

answered, and list the available choices.  

4. To insert a text box where users can enter their responses, click the document, and 

then click Text Form Field on the Forms toolbar. If you need more space, you can 

insert multiple text boxes side by side.  To insert check boxes that list choices, 

such as Yes and No, click the document, and then click Check Box Form Field on 

the Forms toolbar. 

5. Save the form.  

Insert line numbers: 

1. On the File menu, click Page Setup, and then click the Layout tab.  

2. In the Apply to box, click Whole document.  

3. Click Line Numbers.  

4. Select the Add line numbering check box, and then select the options you want. 
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TASK 11: 

Creating a Scheduler:-Features to be covered: - Gridlines, Format Cells, 

Summation, auto fill, Formatting Text 

PURPOSE: 

To maintain a shift schedule with specifications 

 THEORY: 

  Grid lines: 

 

1. Click the worksheet. 

2. On the file menu, click page setup and the click the sheet tab. 

3. Click gridlines. 

4. Select the sheets on which you want to change the gridlines color. 

5. On the Tools menu click options click the color you want in the color box. 

6. To use the default gridlines color click automatic. 

7. Lines you can add to a chart that make it easier to view and evaluate data. 

Gridlines extend from the tick marks on an axis across a plot area. 

 

 Format Cell: 
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1. Change the font and font size. 

2. Change the text color. 

3. Make selected text or numbers bold, italic or underlined. 

4. Create a new style. 

Auto fit: 

 

1. Combine cells horizontally or vertically to make one large cell. 

2. Add borders to cells. 

3. Shade cells with colors. 

4. Change the column width and row height 

5. Change the font, font size or colors of text. 

6. Align text vertically at the top, center and bottom of cell. 

  Formatting the text: 

 

1. Select the text you want to format. 
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2. On the format menu click cells and then click number tab. 

3. In the catalog box click text. 

4. Enter the numbers in the formatted cells. 

5. Click ok. 

6. Then press enter and reenter the data. 

 

PROCEDURE: 

 First click start button of the screen on status bar. Click on programs and then 

Microsoft excel. To get a new blank work sheet go to programs and then click on excel 

sheet. On the file menu click page setup and then click sheet tab click gridlines. In this 

way do the required changes using format cell, make the required changes using 

formatting text also make the required changes. Enter the data in the data in the 

worksheet consisting of week name person name and timings 7 a.m. to 3 p.m. Make all 

the above changes to the text. 
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TASK 12: 

Calculating GPA-Features to be covered-Cell Referencing, Formulae in excel – 

average, std. deviation, Charts, Renaming and Inserting worksheets, Hyper linking, 

Count Function, HLOOKUP/VLOOKUP 

 

PURPOSE: 

To maintain a control chart for printing books with given data. 

THEORY: 

1. On the chart menu click chart type 

2. Text direction. 

Click the arrow down next to the text direction button. For right to left click right to 

left. For left to right reading order, click left to right.  

For reading order that is consistent with the language of the first entered character, 

click context. For reading order that is inconsistent with the language of the first 

entered character, click control. 

     3. In the tools menu click options and then click chart tab. 

     4. To show all worksheet data in the chart even if some rows and columns are hidden, 

clear the plot visible cells by check box. 

5. To prevent hidden rows and columns from displaying in the chart, select the plot 

cells only check box. 

Hyper Linking: 
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1. Create a worksheet: On the file menu, click new, and then click blank 

workbook task pane. 

2. Insert a worksheet: C lick worksheet on the insert menu. Right click on sheet 

tab and then click insert double click the template for the type of sheet you want. 

3. Hyperlink:  Using hyperlink we can insert one more sheet in the present sheet 

4. Count function:  Create a blank worksheet press control +c. In the worksheet 

select cell A and press control +c. On the tools menu point to formula auditing 

and then click formula auditing menu. 

 

Worksheet: 

 

 In the file menu go to menu then a new worksheet is created. 

 To add a single worksheet, click worksheet on the Insert menu.  

 To add multiple worksheets hold down shift and then click the number of 

worksheet tasks to add in a open workbook 

Sort:  
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1. Click a cell in the list you want to sort. 

2. On the Data menu click sort. 

3.  Under first key sort click the custom sort order you want and then click ok. 

4. Click any other sorting option you want. 

PROCEDURE: 

Formulae in Excel: 

 

First click on start button at the bottom of the screen on status bar. Click on 

programs and then on Microsoft excel. Then open a new document. Give the main 

heading and subheading by changing the size so that they look in block letters. Enter the 

data. To calculate go to Insert menu in the menu bar and then click on function and then 

ok. Then select the data to which you want to calculate mean. Then you get the required 

answer. In same way, sample means standard deviation lower count limit and upper count 

limit. Go to insert menu and click on function and select the required operation to be 

done and select the data and calculate. Formulas for all the above are given below. 

Mean = (s1 + s2 + s3 + s4 + s5)/5; 

Sample mean = avg (mean) 

Standard deviation = (mean, sample, mean) 

Sample standard déviation= avg (Standard déviation) 

Lower count limit = sample mean – sample standard deviation. 

Upper count limit = Sample mean + Sample Standard deviation 
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WORKSHEET 

 

                    First click on start button at the bottom of the screen on status bar. Click on 

programs and then Ms-excel. Then enter the data as given. Enter the student’s names, 

Subjective wise marks, total and avg. Then calculate the total and avg by using formula. 

Then go to Data menu and click sort.  
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TASK 13: 

Performance Analysis-Features to be covered:-split cells, freeze panes, group and 

outline, sorting, Boolean and logical operators, Conditional formatting 

PURPOSE:  

       To create Excel with split cells, freeze panes, group and outline, sorting, Boolean and 

logical operators, conditional formatting  

THEORY: 

Split Cells: 

 

Excel allows you to split the workbook window into two horizontal or vertical panes and 

also to split cells or data across many cells. 

Sort:  

5. Click a cell in the list you want to sort. 

6. On the Data menu click sort. 

7.  Under first key sort click the custom sort order you want and then click ok. 

Click any other sorting option you want 

Freeze Panes: 

 You can freeze a pane from a split window or just freeze rows or columns without 

splitting the window. 

PROCEDURE: 

Sort: 
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 First click on start button at the bottom of the screen on status bar. Click on 

programs and then Ms-excel. Then enter the data as given. Enter the student’s names, 

Subjective wise marks, total and avg. Then calculate the total and avg by using formula. 

Then go to Data menu and click sort. Under first key sort, click custom sort order needed 

i.e. ascending order or alphabetical order and then click o.k. Then the required worksheet 

is prepared 

Split cells: 

 

 

Spread the content of one cell over many cells 

1. Copy the data you want into the upper-leftmost cell within the range.  

2. Select the cells you want to merge.  

3. To merge cells in a row or column and center the cell contents, click Merge and 

Center on the Formatting toolbar.  

 

Split merged cells 

 

1. Select the merged cell  When cells have been combined, Merge and Center on 

the Formatting toolbar is selected 

2. Click Merge and Center on the Formatting toolbar.  

 

www.FirstRanker.com www.FirstRanker.com

www.FirstRanker.com



www.F
irs

tR
an

ke
r.c

om

B.TECH 1 YEAR-2nd SEMESTER                                          COMPUTER SCIENCE & ENGINEERING 

VSM COLLEGE OF ENGINEERING                   72                                           IT WORKSHOP 

 

Divide text across cells  

 

1. Select the range of cells that contains the text values. The range can be any 

number of rows tall, but no more than one columns wide.  

2. On the Data menu, click Text to Columns.  

3. Follow the instructions in the Convert Text to Columns Wizard to specify how 

you want to divide the text into columns.  

Split Windows: 

1. At the top of the vertical scroll bar or at the right end of the horizontal scroll bar, 

point to the split box.  

2. When the pointer changes to a split pointer, drag the split box down or to the left 

to the position you want.  

Freeze Panes: 

1. To freeze a pane, do one of the following:  

The top horizontal pane    Select the row below where you want the split to 

appear. 

The left vertical pane    Select the column to the right of where you want the 

split to appear. 

Both the upper and left panes    Click the cell below and to the right of where 

you want the split to appear. 

2. On the Window menu, click Freeze Panes.  

Outline: 
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1. Outline the data automatically 

1. Select the range of cells you want to outline. To outline the entire 

worksheet, click any cell on the worksheet. 

2. On the Data menu, point to Group and Outline, and then click Auto 

Outline. Outline the data manually 

3. Select the rows or columns that contain detail data.  

4. On the Data menu, point to Group and Outline, and then click Group. 

The outline symbols appear beside the group on the screen. 

5. Continue selecting and grouping detail rows or columns until you have 

created all of the levels you want in the outline.  

Group: 

Group objects 

1. Select the objects you want to group.  

To select multiple objects, hold down SHIFT while you select each object. 

2. On the Drawing toolbar, click Draw, and then click Group.  

Ungroup objects 

1. Select the group you want to ungroup.  

2. On the Drawing toolbar, click Draw, and then click Ungroup.  

To continue ungrouping, click Yes when the message box appears. 

To change an individual object, continue to select and ungroup objects until the 

one you want becomes available. 

3. Use the tools on the Drawing toolbar to change the object 

Conditional Formatting: 
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1. Select the cells for which you want to add, change, or remove conditional 

formatting  

2. On the Format menu, click Conditional Formatting.  

3. Do one of the following:  

Add a conditional format 

1. Do one of the following:  

To use values in the selected cells as the formatting criteria, click Cell 

Value Is, select the comparison phrase, and then type a constant value or a 

formula. If you enter a formula, start it with an equal sign (=). 

To use a formula as the formatting criteria (to evaluate data or a condition 

other than the values in selected cells), click Formula Is and then enter 

the formula that evaluates to a logical value of TRUE or FALSE. 

2. Click Format.  

3. Select the formatting you want to apply when the cell value meets the 

condition or the formula returns the value TRUE.  

4. To add another condition, click Add, and then repeat steps 1 through 3.  

You can specify up to three conditions. If none of the specified conditions 

are true, the cells keep their existing formats 
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TASK 14: 

Cricket Score card-Features to be covered:-pivot tables, Interactive Buttons, 

Importing data, Data Protection, Data validation 

 

PURPOSE: To learn about pivot tables, Interactive Buttons, Importing data, Data 

Protection, Data validation. 

THEORY: 

 

1. Pivot Tables:A PivotTable report is an interactive table that quickly combines 

and compares large amounts of data. You can rotate its rows and columns to see 

different summaries of the source data, and you can display the details for areas of 

interest. 

2. Interactive Buttons:MS- Excel allows you to create Interactive Buttons 

3. Data Protection:Ms excel allows you to protect your work sheet from being 

added or renamed or deleted or copied   by providing password protection to your 

worksheets. 

4. Data Validation:Data validation is a tool that helps you to control the kind of 

information that is entered in your worksheet. With data validation you can: 

 Provide users with a list of choices 

 Restrict entries to a specific type or size 

 Create custom settings 

 

PROCEDURE: 

Pivot Tables: 

1. Open the workbook where you want to create the PivotTable report.  

o If you are basing the report on a Web query, parameter query, report 

template, Office Data Connection file, or query file, retrieve the data into 

the workbook, and then click a cell in the Microsoft Excel list containing 

the retrieved data. 

If the retrieved data is from an OLAP database, or the Office Data 

Connection returns the data as a blank PivotTable report, continue with 

step 6 below.If you are basing the report on an Excel list or database, click 

a cell in the list or database. 

2. On the Data menu, click PivotTable and PivotChart Report.  
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3. In step 1 of the PivotTable and PivotChart Wizard, follow the instructions, and 

click PivotTable under What kind of report do you want to create?  

4. Follow the instructions in step 2 of the wizard.  

5. Follow the instructions in step 3 of the wizard, and then decide whether to lay out 

the report onscreen or in the wizard.  

Button: 

 Select the commands tab 

 Scroll to the bottom of the categories list 

 Select the custom button 

 Drag this button to your new toolbar in the location where you want it to 

be. 

 You can obtain a description of the command button by selecting the 

command and pressing the Description  button 

Data Protection: 

Protect worksheet elements from all users 

1. Switch to the worksheet you want to protect. 

2. Unlock any cells you want users to be able to change: select each cell or range, 

click Cells on the Format menu, click the Protection tab, and then clear the 

Locked check box. 

3. Hide any formulas that you don't want to be visible: select the cells with the 

formulas, click Cells on the Format menu, click the Protection tab, and then 

select the Hidden check box. 

4. Unlock any graphic objects you want users to be able to change. 

 

You don't need to unlock buttons or controls for users to be able to click and use 

them. You can unlock embedded charts, text boxes, and other objects created with the 

drawing tools that you want users to be able to modify. To see which elements on a 

worksheet are graphic objects, click Go To on the Edit menu, click Special, and then 

click Objects. 

1. Hold down CTRL and click each object that you want to unlock.  

2. On the Format menu, click the command for the object you selected: 

AutoShape, Object, Text Box, Picture, Control, or WordArt.  

3. Click the Protection tab.  
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4. Clear the Locked check box, and if present, clear the Lock text check 

box.  

5. On the Tools menu, point to Protection, and then click Protect Sheet. 

6. Type a password for the sheet. 

7. In the Allow all users of this worksheet to list, select the elements that you want 

users to be able to change. 

8. Click OK, and if prompted retype the password. 

Protect a shared workbook 

1. If the workbook is already shared, and you want to assign a password to protect 

the sharing, unshare the workbook. 

1. Have all other users save and close the shared workbook. If other users are 

editing, they will lose any unsaved work.  

2. Unsharing the workbook deletes the change history. If you want to keep a 

copy of this information, print out the History worksheet or copy it to 

another workbook.  

1. On the Tools menu, point to Track Changes, and then click 

Highlight Changes.  

2. In the When box, click All.  

3. Clear the Who and Where check boxes.  

4. Select the List changes on a new sheet check box, and then click 

OK.  

5. Do one or more of the following:  

 To print the History worksheet, click Print .  

 To copy the history to another workbook, select the cells 

you want to copy, click Copy, switch to another workbook, 

click where you want the copy to go, and click Paste .  

3. On the Tools menu, click Share Workbook, and then click the Editing 

tab.  

4. Make sure that you are the only person listed in the Who has this 

workbook open now box.  

5. Clear the Allow changes by more than one user at the same time check 

box.  
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If this check box is not available, you must unprotect the workbook before 

clearing the check box. 

1. Click OK, point to Protection on the Tools menu, and then click 

Unprotect Shared Workbook.  

2. Enter the password if prompted, and then click OK.  

3. On the Tools menu, click Share Workbook, and then click the 

Editing tab.  

6. When prompted about the effects on other users, click Yes.  

2. Set other types of protection if you want: Give specific users access to ranges, 

protect worksheets, protect workbook elements, and set passwords for viewing 

and editing. 

3. On the Tools menu, point to Protection, and then click Protect Shared 

Workbook or Protect and Share Workbook. 

4. Select the Sharing with track changes check box. 

5. If you want to require other users to supply a password to turn off the change 

history or remove the workbook from shared use, type the password in the 

Password box, and then retype the password when prompted. 

6. If prompted, save the workbook 

 

Data Validation: 

 Select the cells in which you want to apply data validation 

 From the Data menu, choose Validation 

 From the Allow drop-down list choose List 

 In the source box type an equal to sign and list the name  

 Click ok 
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TASK 15: 

PPT Orientation, Slide Layouts, Inserting Text, Word Art, Formatting Text, Bullets 

and Numbering, Auto Shapes, Lines and Arrows in both LaTeX and PowerPoint. 

TITLE:  

 Create a power point presentation consists of slide layouts inserting text, 

formatting text, bullets and numbering of five slides with following information’s. 

Slide 1 – contents 

Slide 2 – Name 

Slide 3 – Address 

Slide 4 – Hobbies 

Slide 5 – Friends 

PURPOSE: 

 To maintain a PowerPoint presentation with some specifications 

THEORY: 

SLIDE LAYOUT:  

 

1. On the format menu, click slide layout. 

2. On the slides tab in normal view, select the slides; you want to apply a layout 

too. 

3. In the slide layout task pane, point to layout you and then click it. 
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4. A new slide can also be inserted within the task pane. Point the layout you 

want the slide to have, click the arrow and then click the insert new slide. 

INSERT TEXT:  

 

1. Text can be added to layout. 

2. Align text in the top, middle or bottom of a cell. 

3. Align text on the right or left, or in the center of a cell. 

4. Change cell margins. 

5. Insert a tab in a table. 

6. To make the symbol command available, in normal view, place the insertion 

point on the outbox tab or in a text place holders on the slide. 

7. On the insert menu, click symbol. 

8. To change fonts, click a name in the font box. 

FORMATTING TEXT: 

 

1. Select the text you want to format as superscript or subscript. 

2. On the format menu, click font. 

3. To show or hide text formatting, on the standard toolbar, click show 

formatting. 

 

        

www.FirstRanker.com www.FirstRanker.com

www.FirstRanker.com



www.F
irs

tR
an

ke
r.c

om

B.TECH 1 YEAR-2nd SEMESTER                                          COMPUTER SCIENCE & ENGINEERING 

VSM COLLEGE OF ENGINEERING                   81                                           IT WORKSHOP 

 

LINES AND ARROWS:  

 

1. In Microsoft power point, double click the chart. 

2. Double click the chart item you want to change. 

3. On the patterns tab, do one or both of the following. 

4. To change the colors, patterns or lines, select the options you want. 

5. To specify a fill effect, click fill effect and then select the options you want on 

the gradient, text patterns or picture tabs. 

To return to the slide, click outside the about. 

 

PROCEDURE: 

 First click on start button at the button of the screen on status bar. Click on 

programs and then Microsoft PowerPoint. Go to file and new. Then you find different 

pattern of slides on right side of your screen. Then select which is completely empty. 

Then enter the contents in the first slide as per given information, name in the second 

slide, Address in the third slide, Hobbies in the fourth slide and friends in the fifth slide. 

Except first slide, all the second, third, fourth, fifth slides should be inserted. When you 

select pattern of slide from a new slide, on slide which you selected you will find an 

arrow towards its right side, click that arrow and then again click insert slide. Then save 

it. Then adjust the layout. Then format the text then give bullets or numbering to the text 

if required. Go to auto shapes. Select more auto shapes and insert wherever required. 

Then again go to insert option and select new slides. And select chart and a chart with 

datasheet appear. Give the name, roll no, marks in three subjects and calculate the total. 

Then save the file 

 

 

 

 

 

 

 

 

www.FirstRanker.com www.FirstRanker.com

www.FirstRanker.com



www.F
irs

tR
an

ke
r.c

om

B.TECH 1 YEAR-2nd SEMESTER                                          COMPUTER SCIENCE & ENGINEERING 

VSM COLLEGE OF ENGINEERING                   82                                           IT WORKSHOP 

 

TASK 21: 

Hyperlinks, Inserting –Images, Clip Art, Audio, Video, Objects, Tables and Charts 

 

TITLE: 

 Create a power point presentation consisting of hyperlinks, inserting images, 

clip art, audio, video objects of 4 slides with the following information. 

 

 Slide 1:- Name of your college in bold letters. 

 Slide 2:- Address of your college in bold letters. 

 Slide 3:- List of all available courses. 

 Slide 4:- Extra co-curricular activities. 

  And apply the transaction effects and set the time three seconds for each 

slide and view it in slide show. 

 

PURPOSE: 

 To maintain a PowerPoint presentation using some specifications 

 

THEORY:  

 

HYPERLINK:  

 

1. Select the text or object that you want to represent the hyperlink. 

2. Click insert hyperlink. 

3. Under link to, click place in this document. 
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INSERT IMAGES: 

 

1. Click where you want to insert the picture. 

2. On the drawing tool bar, click insert picture. 

3. Locate the folder that contains the picture that you want to insert, and then 

click the picture file. 

CLIP ART:  

 

1. On the insert menu, point to structure and then click clipart. 

2. in the clipart task pane, in the search for box, type a word or phrase that 

describes the clip, you want to type in all or same of the file menus of the clip. 

3. in the results box, click the clip to insert it. 
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AUDIO VIDEO OBJECTS: 

 

1. On the slide show menu, click setup show. Under performance check box. If 

your computer has their capability, office PowerPoint will attempt to use it. 

2. Animation performance will be much better with a video card that has 

Microsoft direct 3D. 

TABLE: 

 

1. On the standard tool bar, click insert table. 

2. Print to select the numbers of rows and columns you want and then click. 

      CHART: 

 

1. Click the slide where you want to place the embedded object. 

www.FirstRanker.com www.FirstRanker.com

www.FirstRanker.com



www.F
irs

tR
an

ke
r.c

om

B.TECH 1 YEAR-2nd SEMESTER                                          COMPUTER SCIENCE & ENGINEERING 

VSM COLLEGE OF ENGINEERING                   85                                           IT WORKSHOP 

 

2. On the insert menu, click chart. 

3. Click a cell on the data sheet and then type the information you want. 

To return to the slide, click outside the chart 

 

PROCEDURE: 

 First click on start button at the bottom of the screen on status bar. Click on 

programs and then Microsoft power point go to file menu. Then you find different pattern 

of slides on right side of your screen. Then select which is completely empty. Then enter 

the name of your college in bold letters. Address of your college in bold letters in the 

second slide. List of all the available courses in the third slide, extra co-curricular 

activities in the fourth slide except first slide, all the second, third, fourth slide should be 

inserted. When you select pattern of slide from a new slide, on slide which you selected, 

you will find an arrow towards it right side click that arrow and then again click insert 

slide. Then save it the select the slide show and then select the view show option. Then 

review the presentation in slide show by selecting next and after completing the slide 

show then click end show. Click on start button at the button of the screen on status bar, 

click on programs and then Microsoft power point. Go to file menu. On insert menu and 

select table option and give no. of rows and no. of columns and give the name, Roll no 

and marks in three subjects and find the total 
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TASK 16: 

Master Layouts (slide, template, and notes), Types of views (basic, presentation, 

slide slotted, notes etc), Inserting – Background, textures, Design Templates, Hidden 

slides. 

TITLE: 

 Create a power Point presentation on business by using master layouts and 

see the presentation in different views. 

PURPOSE: 

 To maintain a power point presentation with some specifications 

THEORY:- 

       MASTER LAYOUTS:-  

 

1. On the view menu, point to master, and then click slide master. 

2. To insert a slide master, do the presentation given in slides and lastly add 

date and footer to the slides. 

 

      SLIDE SHOW: 

1. On the slides tab in the normal view, select the slides you want to set the 

things for. 

2. On the slide show menu, click side transition. 

3. Under advance slide, select the automatically after checkbox, and then number 

of seconds you want the slide to appear on the screen. 
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PROCEDURE: 

 First click on start button. Then click programs, and then power point 

presentation. Then select file menu and click on new. Then you get a new blank 

presentation. Then in the first slide, enter the title as business and give product name as 

sub title. Then insert the second slide. Then enter the title as about the product and give 

description as sub title. Then insert the third slide and enter the title as sales about 

product and enter something about it sales. In this way, complete the three slides. Then 

click on view and then master and then enter date in the space provided for footer. Then 

you find these two in all slides and then again go to view and click on slide show. 
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TASK 17: 

Help students in preparing their personal website using Microsoft/ equivalent 

(FOSS) tool publisher. Topic covered during this week includes - Publisher 

Orientation, Using Templates, Layouts, Inserting text objects, Editing text objects, 

Inserting Tables, Working with menu objects, Inserting pages, Hyper linking, 

Renaming, deleting, modifying pages, Hosting website. 

 

PURPOSE: 

To learn Using Templates, Layouts, Inserting text objects, Editing text objects, Inserting 

Tables, Working with menu objects, Inserting pages, Hyper linking, Renaming, deleting, 

modifying pages, and Hosting website. 

 

THEORY: 

 Layouts: 

Layout guides comprise margin, column, row, and baseline guides. They 

are used to create a grid on a master page. This grid appears on every page in your 

publication where that master page is used. Use layout guides to organize text, 

pictures, and other objects into columns and rows so that your publication will 

have an ordered, consistent look. Set layout guides in the Layout Guides dialog 

box (Arrange menu).Margin guides, column guides, and row guides are 

represented by blue dotted lines; baseline guides are represented by gold dotted 

guides; and ruler guides are represented by green dotted lines 

 

 Hyper Link: 

Hyperlink is a link from a document that, when clicked, opens another 

page or file. The destination is frequently another Web page, but it can also be a 

picture, an e-mail address, or a program. The hyperlink itself can be text or a 

picture. 

PROCEDURE: 

Template: 

1. Create the publication you want to use as a template. 

2. On the File menu, click Save As.  

3. In the File name box, type a name for the template.  

4. In the Save as type box, click Publisher Template.  
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The destination folder changes to Templates. You need to save your template in 

this folder if you want it to appear in the Preview Gallery of the New 

Publication task pane later. 

5. Click Save. 

 

InsertingTextObjects: 

In your publication, select an AutoShape 

1. Type the text you want 

Editing Text objects: 

1. Double-click the WordArt object you want to change.  

2. In the Edit WordArt Text dialog box, change the text, and then click OK. 

Inserting Tables: 

1. On the Objects toolbar, click the Insert Table.  

2. Click inside your publication.  

The Create Table dialog box will appear. 

3. Select the options you want, and then click OK.  

4. Size your table.  

Select the table, position the mouse pointer over a selection handle until you see 

the Resizer icon, and then drag to resize the table. 

5. In the table, click the cell where you want to add text, and then start typing.  

To add text to another cell, click inside that cell. 

Each cell expands to fit your text, unless you lock the table size by clearing the 

check mark next to Grow to Fit Text on the Table menu. 

Hyperlink: 

 

Create a hyperlink to a file or page 
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1. Select either text or a picture.  

2. Click Insert Hyperlink.  

3. Under Link to, click Existing File or Web Page.  

4. Do one of the following:  

o To select a file from your My Documents folder, click Current Folder.  

o To select a file that was recently viewed in your Web browser, click 

Browsed Pages.  

o To select a file that you were recently working in, click Recent Files.  

5. Navigate to the file or page you want.  

Create a hyperlink to an e-mail address 

1. Select either text or a picture.  

2. Click Insert Hyperlink.  

3. Under Link to, click E-mail Address.  

4. Either type the e-mail address you want in the E-mail address box, or select an e-

mail address from the recently used e-mail addresses box.  

5. In the Subject box, type the subject of the e-mail message. 

Create a hyperlink to another place in your document 

1. Select either text or a picture.  

2. Click Insert Hyperlink.  

3. Under Link to, click Place in This Document.  

4. Select the page you want 

Create a hyperlink to a new page 

1. Select either text or a picture.  

2. Click Insert Hyperlink.  

3. Under Link to, click Create New Document.  

4. Either type the path and name of the new file, or click Change to navigate to a 

location.  

5. Select either Edit the new document later or Edit the new document now.  

 

 

 

 

 

 

www.FirstRanker.com www.FirstRanker.com

www.FirstRanker.com



www.F
irs

tR
an

ke
r.c

om

B.TECH 1 YEAR-2nd SEMESTER                                          COMPUTER SCIENCE & ENGINEERING 

VSM COLLEGE OF ENGINEERING                   91                                           IT WORKSHOP 

 

Pages: 

 

Create a master page 

1. On the View menu, click Master Page.  

2. In the Edit Master Pages task pane, click New Master Page.  

3. In the New Master Page dialog box, do any of the following:  

o In the Page ID (1 character) box, type a single-character identifier for 

your new master page. This can be any single Unicode character.  

o In the Description box, type a brief description of your new master page.  

o If you want your new master page to be a two-page spread, select Two-

page master.  

4. Click OK.  

Edit a master page 

1. On the View menu, click Master Page.  

2. In the Edit Master Pages task pane, click the arrow next to the master page you 

want to edit, and then click Edit.  

3. Edit the page as desired.  

4. To see the updated publication pages, click View publication pages, and then 

navigate to a page to which the master page is applied 

Delete a master page 

1. On the View menu, click Master Page.  

2. In the Edit Master Pages task pane, click the arrow next to the master page you 

want to delete, and then click Delete.  

3. In the alert box, click Yes 
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